0 голосов

Здравствуйте. По инструкции набора "Планета XOD" компилирую патч led с яркостью 100% (1) - всё работает. После этого уменьшаю яркость до 0,5 и компилирую снова. И в этот момент протокол оканчивается этим:

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding avrdude: butterfly_recv(): programmer is not responding

долго жду, далее нажимаю ресет и ...

a butterfly/AVR109 but a AVR910 device?
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: ser_send(): write error: sorry no info avail
avrdude: ser_recv(): read error: ���������� �� �������� �������.


avrdude: butterfly_recv(): programmer is not responding

avrdude: error: programmer did not respond to command: leave prog mode

avrdude: ser_send(): write error: sorry no info avail
avrdude: ser_recv(): read error: ���������� �� �������� �������.

avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: exit bootloader

avrdude done.  Thank you.


Error: exit status 1
Error during upload.
Upload failed
Command Process exited with code 1
Make sure the board is connected, the cable is working, the board model set correctly, the upload port belongs to the board, the board drivers are installed, the upload options (if any) match your board specs.

Потом поменял плату на новую и опять по инструкции и опять тоже самое. Что не так принципиально я могу делаьб?

Спасибо.

(2 баллов) 1

1 Ответ

0 голосов

Если кабель живой, подключен  хорошо, правильно выбран тип платы при загрузке (должно быть Arduino Leonardo, а не Uno)... тогда похоже вы в процессе экспериментов срубили загрузчик на контроллере. Восстановить его можно, но понадобится дополнительная Arduino UNO (которая будет программатором).

Смотреть тут

(204 баллов) 1 3 13
Спасибо за ответ. Я понял что я сделал, но не понимаю как не делать этого дальше. Инструкция конечно не доскональная в наборе... после того как залил один патч, загорелся диод на 100%, я изменил параметр яркости на 50% и заливаю патч ещё раз. На этом этапе происходит сбой загрузчика уже на второй плате. Что может быть не так в моих действиях? Вторую плату уже меняю. Ошибку так и не нашёл.Спасибо
Добро пожаловать на Бредборд! Сайт вопросов и ответов на тему Arduino, Raspberry Pi и хоббийной электроники в целом. Цель Бредборда — быть максимально полезным. Поэтому мы строго следим за соблюдением правил, боремся с холиворами и оффтопиком.
  1. parovoZZ

    18 балл(ов)

  2. sser

    12 балл(ов)

  3. Тигрыч

    8 балл(ов)

  4. Un_ka

    8 балл(ов)

  5. artalex

    6 балл(ов)

  6. Vitalii_Mashinkin

    2 балл(ов)

Награды месяца
1-е место: Teensy 3.6
2-е место: Teensy 3.5
3-е место: Teensy 3.2

...